- Home
- Components
- Wired Routers
- TP-Link TD-W8961N

TP-Link · Wired Routers
TP-Link TD-W8961N
1 shop · history since 26 Jul 2026 (106 days)
- Cabling technology
- 10/100Base-T(X)
- Ethernet LAN data rates
- 10,100 Mbit/s
- Ethernet LAN interface type
- 10/100Mbps
- Networking standards
- IEEE 802.3, IEEE 802.3u
Price · only 1 shop
2 490 lekLowest in 90 daysOnly in 1 shop
at Shpresa-Al
Only this shop has it. There is no other price to compare; the reading uses this shop's own history.
Go to Shpresa-AlYou buy at the shop. Price and stock may change after the last check.
ReadingSteady price
The price has stayed at 2 490 L for the last 30 days.
Offers
Only one shop we follow has this product.
| Shop | Offer | Delivery | Freshness | Price | Go to |
|---|---|---|---|---|---|
Shpresa-Al | New | No data | 2 490 lek | Go to Shpresa-AlGo |
Price history
Lowest price of the day at verified shops · data since 26 Jul 2026
2 400 L2 600 L2 800 L3 000 L3 200 L3 400 L11 Aug2 Sep25 Sep17 Oct8 NovLast 30 daysToday 2 490 L
Lowest in 90 days: 2 490 L · 11 Aug
- 30-day median · 2 490 L
- Today · 2 490 L
| Date | Price from this day | Shop |
|---|---|---|
| 30 Sep 2026 | 2 490 L | Shpresa-Al |
| 22 Sep 2026 | 3 290 L | Shpresa-Al |
| 11 Aug 2026 | 2 490 L | Shpresa-Al |
Dashed line: the median of the last 30 days. The price moves in steps because we keep one price a day.
- Lowest · 30 days
- 2 490 L
- 30-day median
- 2 490 L
- Highest · 30 days
- 2 490 L
- Price changes · 30 days
- 0
- Lowest · 90 days
- 2 490 L
- 30-day median
- 2 490 L
- Highest · 90 days
- 3 290 L
- Price changes · 90 days
- 2
- Lowest · 106 days
- 2 490 L
- 30-day median
- 2 490 L
- Highest · 106 days
- 3 290 L
- Price changes · 106 days
- 2
Specifications
Source: Icecat, maker · only the fields we hold are shown
Network
| Cabling technology | 10/100Base-T(X) |
|---|---|
| Ethernet LAN | Yes |
| Ethernet LAN data rates | 10,100 Mbit/s |
| Ethernet LAN interface type | 10/100Mbps |
| Networking standards | IEEE 802.3, IEEE 802.3u |
| Top Wi-Fi standard | IEEE 802.11n |
Operational conditions
| Operating relative humidity (H-H) | 10 - 90% |
|---|---|
| Operating temperature (T-T) | 0 - 40 °C |
| Storage relative humidity (H-H) | 5 - 90% |
| Storage temperature (T-T) | -40 - 70 °C |
Ports & interfaces
| Ethernet LAN (RJ-45) ports | 4 |
|---|---|
| Memory card slot(s) | No |
| RJ-11 ports quantity | 1 |
| USB port | No |
Show all 53 specifications
WAN connection
| 3G/4G USB modem compatibility | No |
|---|---|
| DSL WAN | Yes |
| Ethernet WAN | Yes |
| SIM card slot | No |
Antenna
| Antenna design | Omni directional, Fixed Antenna |
|---|---|
| Antenna gain level (max) | 5 dBi |
| Transmit power | 20 dBmW |
System requirements
| Linux operating systems supported | Yes |
|---|---|
| Mac compatibility | Yes |
| Mac operating systems supported | Yes |
Weight & dimensions
| Depth | 130 mm |
|---|---|
| Height | 35 mm |
| Width | 195 mm |
DSL features
| ADSL | Yes |
|---|---|
| ADSL2 | Yes · Yes |
Mobile network
| 3G | No |
|---|---|
| 4G | No |
Protocols
| DHCP client | Yes |
|---|---|
| Supported network protocols | ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364), PPP over Ethernet (RFC2516), IPoA (RFC1577/2225), PVC - Up to 8 PVCs |
Wireless LAN features
| Wi-Fi band | 2.400-2.4835 GHz |
|---|---|
| WLAN data transfer rate (max) | 300 Mbit/s |
Design
| Product type | ADSL2+ Modem Router |
|---|
Features
| Windows operating systems supported | Windows 2000, Windows 2000 Professional, Windows 7, Windows 7 Enterprise, Windows 7 Enterprise x64, Windows 7 Home Basic, Windows 7 Home Basic x64, Windows 7 Home Premium, Windows 7 Home Premium x64, Windows 7 Professional, Windows 7 Professional x64, Windows 7 Starter, Windows 7 Starter x64, Windows 7 Ultimate, Windows 7 Ultimate x64, Windows 7 x64, Windows 8, Windows 8 Enterprise, Windows 8 Enterprise x64, Windows 8 Pro, Windows 8 Pro x64, Windows 8 x64, Windows 8.1, Windows 8.1 Enterprise, Windows 8.1 Enterprise x64, Windows 8.1 Pro, Windows 8.1 Pro x64, Windows 8.1 x64, Windows 98SE, Windows NT, Windows Vista, Windows Vista Business, Windows Vista Business x64, Windows Vista Enterprise, Windows Vista Enterprise x64, Windows Vista Home Basic, Windows Vista Home Basic x64, Windows Vista Home Premium, Windows Vista Home Premium x64, Windows Vista Ultimate, Windows Vista Ultimate x64, Windows Vista x64, Windows XP, Windows XP Home, Windows XP Home x64, Windows XP Professional, Windows XP Professional x64 |
|---|
Management features
| Quality of Service (QoS) support | Yes |
|---|
Power
| Output voltage | 9 V |
|---|
Security
| Security algorithms | 64-bit WEP, 128-bit WEP, WPA-PSK, WPA2-PSK |
|---|
Other features
| Certification | CE, FCC, RoHS |
|---|---|
| Transmission encryption | Yes |
Technical details
| (sg) Manufacturer Part Number | TD-W8961N |
|---|
Packaging content
| AC adapter included | Yes |
|---|---|
| Cables included | LAN (RJ-45), Phone (RJ-11) |
| Number of products included | 1 pc(s) |
| Quick installation guide | Yes |
Packaging data
| Package depth | 232 mm |
|---|---|
| Package height | 70 mm |
| Package type | Box |
| Package weight | 590 g |
| Package width | 285 mm |
Logistics data
| Harmonized System (HS) code | 85176990 |
|---|